pondělí 14. května 2012

Sakra, Conky 1.9.0 už tu máme...

Před pár dny jsem tu řešil stoleté zabugované Conky 1.8.1 a nabízel neoficiální conky 1.8.2. Ani jsem si nevšiml, že ve stejný den vyšla nová verze 1.9.0 zcela oficiálně.
V repozitářích Ubuntu zatím není, ale opět můžeme využít práce jiných, kteří za nás kompilovali a balili. Můžete například, jako já, využít repozitáře Vincenta Chenga, který ubalil předevčírem:

https://launchpad.net/~vincent-c/+archive/conky/

Můžete instalovat i bez přidávání ppa, 64bit verze ke stažení zde:

https://launchpad.net/~vincent-c/+archive/conky/+build/3481864

Rovnou musím říct, že mnou odkazované 1.8.2 nutilo na mém systému xorg ke konzumaci více než deseti procent výkonu procesoru a to u Chengova 1.9.0 zmizelo. Takže já jsem zatím spokojen, nic se nerozhodilo, ba naopak, a všechno mi zatím šlape.

Nová verze je čistě udržovací, opravuje jen chyby, žádné novinky nepřináší. Ostatně udržovací byla i verze 1.8.1, která ale před rokem a půl přinesla do Conky hlavně zásadní chyby, které tam celou tu dobu hnily. Autor se omlouvá, že je časově zaneprádněn a já mu odpouštím :)

Update: Zdá se, že všechny chyby ještě odstraněny nebyly, ale mně zatím žádné nezasáhly..
http://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=conky;dist=unstable#_4_4_5

4 komentáře:

  1. Ahoj...

    Jak už jsem Ti kdysi psal, používal jsem a používám značnou část Tvých skriptů v úpravě na Mageia2... (Dříve Mandriva Linux).
    Na Mageia2 jsou v repo conky 1.8.1 S těmi jsem měl problémy ve skriptech removable_drives.sh a currencies.py - rozhazovalo to řádky.
    Tak jsem stáhnul a nakompiloval conky 1.9.0. Vše super, vše se zobrazuje a funguje správně. Až na obrázek. V conkyrc mám řádek ${image ~/.conky/gln2.png -s 300x60 -p 5,0} . V conky 1.8.1 se normálně zobrazil, v 1.9.0 se obrázek nezobrazí, výsledkem je pouze text ${image}. V terminálu conky hlásí chybu: Conky: unknown variable image. Nevíš, co to může znamenat???
    Vyzkoušel jsem vše možné... Při hledání na Google tato hláška říká něco o imlib2 (tento balík mám nainstalovaný) nebo lua... S tím nemám zkušenosti... Můžeš mne nějak nakopnout??? Dík, Jirka.
    P.S. Sorry, že píšu takhle přes komentář... J.

    OdpovědětSmazat
    Odpovědi
    1. Hola! Při kompilaci je třeba podporu obrázků povolit, tedy spustit před kompilací konfiguraci s patřičnými parametry. Kdysi jsem to tu taky popisoval.. Jiný důvod by v tom být neměl, pokud hlásí, že nezná proměnnou.

      Smazat
    2. Ahoj...

      Dík za nakopnutí. S istalací přes "./configure, make, make install" nemám moc zkušeností, moc to nepoužívám... Pomohlo to, dal jsem podporu obrázků, chtělo to po mně přidat ještě jednu knihovnu... a hotovo... Funguje. Jirka

      Smazat

Zkuste prosím při komentováni používat místo volby Anonymní volbu Název/adresa URL, kde vyplníte nějakou přezdívku, adresu zadávat nemusíte. Vědět, které příspěvky jsou od jednoho člověka, je fajn. Díky.

Pokud by se vám náhodou odeslaný komentář na stránce nezobrazil, vytáhnu ho z koše hned jak si toho všimnu. I Google spam filter se občas sekne.